数据结构实验之图论六:村村通公路

数据结构实验之图论六:村村通公路

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

当前农村公路建设正如火如荼的展开,某乡镇政府决定实现村村通公路,工程师现有各个村落之间的原始道路统计数据表,表中列出了各村之间可以建设公路的若干条道路的成本,你的任务是根据给出的数据表,求使得每个村都有公路连通所需要的最低成本。

Input

连续多组数据输入,每组数据包括村落数目N(N <= 1000)和可供选择的道路数目M(M <= 3000),随后M行对应M条道路,每行给出3个正整数,分别是该条道路直接连通的两个村庄的编号和修建该道路的预算成本,村庄从1~N编号。 

Output

输出使每个村庄都有公路连通所需要的最低成本,如果输入数据不能使所有村庄畅通,则输出-1,表示有些村庄之间没有路连通。 

Sample Input

5 8
1 2 12
1 3 9
1 4 11
1 5 3
2 3 6
2 4 9
3 4 4
4 5 6

Sample Output

19

Hint

 

Source

xam

// 最小生成树Kruskal算法(并查集思想)
#include<bits/stdc++.h>
using namespace std;
struct node
{
	int u,v,w;
}e[1010];
int n,f[1010];
bool cmp(node a,node b)
{
	return a.w<b.w;
}
void init()
{
	for(int i=1;i<=n;i++)
	{
		f[i]=i;
	}
}
int find_root(int i)
{
	if(f[i]==i)
	{
		return f[i];
	}
	else
	{
		f[i]=find_root(f[i]);
		return f[i];
	}
}
bool Merge(int u,int v)
{
	int t1=find_root(u);
	int t2=find_root(v);
	if(t1==t2)
	{
		return true;
	}
	else
	{
		f[t2]=t1;
		return false;
	}
}
int main()
{
	int m;
	while(cin>>n>>m)
	{
		init();
		for(int i=1;i<=m;i++)
		{
			cin>>e[i].u>>e[i].v>>e[i].w;
		}
		sort(e+1,e+1+m,cmp);
		int ans=0,cnt=0;
		for(int i=1;i<=m;i++)
		{
			if(cnt==n-1)
			{
				break;
			}
			if(!Merge(e[i].u,e[i].v))
			{
				ans=ans+e[i].w;
				cnt++;
			}
		}
		if(cnt==n-1)
		{
			cout<<ans<<endl;
		}
		else
		{
			cout<<"-1"<<endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值