树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:
4 1 6 3 5 7 2

#include <stdio.h>
#include <stdlib.h>
typedef struct BiTNode
{
    int data;
    struct BiTNode *lchild;
    struct BiTNode *rchild;
}BiTNode,*BiTree;
BiTree CreatBinTree(int *post,int *in,int n )
{
	BiTree T;
	int i;
	if (n<=0) return NULL;
	T=(BiTree)malloc(sizeof(BiTNode));
	T->data=post[n-1];
	for(i=0;in[i]!=post[n-1];i++);
	T->lchild = CreatBinTree(post, in, i);
	T->rchild=CreatBinTree(post + i, in + i + 1, n - i - 1);
	return T;
}
void Levelorder(BiTree T)
{
	BiTree a[100050];
	int front = 0, rear = 0;
	if (T)
	{
		int j = 0;
		a[rear++] = T;
		while (front != rear)
		{
			BiTree now = a[front];
			if (j==0) printf("%d", now->data);
			else printf(" %d", now->data);
			if (now->lchild) a[rear++] = now->lchild;
			if (now->rchild) a[rear++] = now->rchild;
			front++;
			j++;
		}
	}
}
int main()
{
    BiTree T;
	int n, inlist[100], postlist[100];
	scanf("%d", &n);
	for (int i = 0; i < n; i++) scanf("%d", &postlist[i]);
	for (int i = 0; i < n; i++) scanf("%d", &inlist[i]);
	T=CreatBinTree(postlist,inlist, n);
	Levelorder(T);
	printf("\n");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值