[USACO06DEC] Cow Picnic S

题目描述

The cows are having a picnic! Each of Farmer John’s K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1…N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

K ( 1 ≤ K ≤ 100 ) K(1 \le K \le 100) K(1K100) 只奶牛分散在 N ( 1 ≤ N ≤ 1000 ) N(1 \le N \le 1000) N(1N1000) 个牧场.现在她们要集中起来进餐。牧场之间有 M ( 1 ≤ M ≤ 10000 ) M(1 \le M \le 10000) M(1M10000) 条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方。那么,有多少这样的牧场可供进食呢?

输入格式

Line 1: Three space-separated integers, respectively: K, N, and M

Lines 2…K+1: Line i+1 contains a single integer (1…N) which is the number of the pasture in which cow i is grazing.

Lines K+2…M+K+1: Each line contains two space-separated integers, respectively A and B (both 1…N and A != B), representing a one-way path from pasture A to pasture B.

输出格式

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

样例 #1

样例输入 #1

2 4 4
2
3
1 2
1 4
2 3
3 4

样例输出 #1

2

提示

The cows can meet in pastures 3 or 4.

1:暴力遍历 pts40

#include <bits/stdc++.h>
#define int long long
using namespace std;
const int K = 110, N = 1010, M = 10010;
int k, n, m, d[N], tot, ans;
map<int, bool> a;
vector<int> e[N];
void dfs(int x) {
	if (a[x] && !d[x]) tot ++ ;
	d[x] = 1;
	for (auto i : e[x])
		if (!d[i])
			dfs(i);
}
signed main() {
	cin >> k >> n >> m;
	for (int u, i = 1; i <= k; cin >> u, a[u] = 1, i ++ );
	for (int i = 1; i <= m; i ++ ) {
		int x, y;
		cin >> x >> y;
		e[x].push_back(y);
	}
	for (int i = 1; i <= n; i ++ ) {
		tot = 0;
		memset(d, 0, sizeof d);
		dfs(i);
		if (tot == k) ans ++ ;
	}
	cout << ans;
}

2:100pts

#include <bits/stdc++.h>
using namespace std;
bool vis[1010];
int k,n,m,ans;
int mk[1010],a[1010];
vector <int> b[1010];
void dfs(int x){
     vis[x]=1;  mk[x]++;
     for(int i=0;i<b[x].size();i++)
         if(!vis[b[x][i]])
             dfs(b[x][i]);
}
int main(){
    int x,y;
    cin>>k>>n>>m;
    for(int i=1;i<=k;i++) cin>>a[i];
    for(int i=1;i<=m;i++) {
        cin>>x>>y;
        b[x].push_back(y);
    }
    for(int i=1;i<=k;i++) { for(int j=1;j<=n;j++) vis[j]=0;  dfs(a[i]);}
    for(int i=1;i<=n;i++) if(mk[i]==k) ans++;
    cout<<ans;
}
  • 13
    点赞
  • 16
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值