Building Shops(dp)

Building Shops

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3881 Accepted Submission(s): 1306

Problem Description
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

Output
For each test case, print a single line containing an integer, denoting the minimal cost.

Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1

Sample Output
5
11

Source
2017中国大学生程序设计竞赛 - 女生专场

Recommend
jiangzijing2015
dp[i][j] 到第i个所花的钱
dp[i][0] 不建超市
dp[i][1] 建超市

#include <stdio.h>
#include <math.h>
#include <queue>
#include <memory.h>
#include <algorithm>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
ll dp[3003][2],disum[3003][3003];
struct node
{
    int x,c;
} a[3003];
int cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int n,i,j;
    ll z;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,INF,sizeof(dp));
        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].c);
        }
        sort(a+1,a+n+1,cmp);  //注意别忘了排序
        for(i=1; i<=n; i++)   //每两个点 以i为超市 
        {                          //i到j中每个店到i的距离
            disum[i][i]=0;        
            for(j=i+1; j<=n; j++)
            {
                disum[i][j]=disum[i][j-1]+a[j].x-a[i].x;
            }
        }
        dp[0][0]=dp[0][1]=0;
        for(i=1; i<=n; i++)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+a[i].c; //在i点建超市
            for(j=1; j<=i; j++)     //不建超市
            {                       //找在哪个j店建超市花费最小
                dp[i][0]=min(dp[i][0],dp[j][1]+disum[j][i]);
            }
        }
        z=min(dp[n][0],dp[n][1]);
        printf("%lld\n",z);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以给你一些指导来创建和使用shops数据库。 首先,你需要安装一个关系型数据库管理系统(RDBMS),例如MySQL、PostgreSQL或Microsoft SQL Server。这些RDBMS都提供了创建和管理数据库的工具。 一旦你安装了RDBMS,你可以使用SQL(结构化查询语言)来创建数据表和插入数据。下面是一个示例的SQL代码来创建一个名为“shops”的数据库: ``` CREATE DATABASE shops; ``` 接下来,你可以创建一个名为“products”的表来存储商品信息,例如商品名称、价格和库存量。下面是一个示例的SQL代码: ``` CREATE TABLE products ( id INT NOT NULL AUTO_INCREMENT, name VARCHAR(255) NOT NULL, price DECIMAL(10,2) NOT NULL, stock INT NOT NULL, PRIMARY KEY (id) ); ``` 这将创建一个名为“products”的表,其中包含四个列:id、name、price和stock。id列是自动增量的主键,确保每个商品都有一个唯一的标识符。name列存储商品名称,price列存储商品价格,stock列存储商品库存量。 一旦你创建了“products”表,你可以使用INSERT语句向表中插入数据。例如,下面是一个示例的SQL代码来插入一些商品信息: ``` INSERT INTO products (name, price, stock) VALUES ('T-shirt', 19.99, 100), ('Jeans', 49.99, 50), ('Sneakers', 79.99, 25); ``` 这将向“products”表中插入三个商品,分别是T-shirt、Jeans和Sneakers,每个商品都有一个价格和库存量。 一旦你向表中插入了数据,你可以使用SELECT语句来查询数据。例如,下面是一个示例的SQL代码来查询所有商品的名称和价格: ``` SELECT name, price FROM products; ``` 这将返回一个结果集,其中包含所有商品的名称和价格。 当然,这只是一个简单的示例,你可以根据自己的需求创建更复杂的表和查询。希望这些指导可以帮助你创建和使用shops数据库。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值