sdut2874师--链表的结点插入

Problem Description

给出一个只有头指针的链表和 n 次操作,每次操作为在链表的第 m 个元素后面插入一个新元素x。若m 大于链表的元素总数则将x放在链表的最后。
Input

多组输入。每组数据首先输入一个整数n(n∈[1,100]),代表有n次操作。
接下来的n行,每行有两个整数Mi(Mi∈[0,10000]),Xi。
Output

对于每组数据。从前到后输出链表的所有元素,两个元素之间用空格隔开。
Sample Input

4
1 1
1 2
0 3
100 4
Sample Output

3 1 2 4
Hint

Source

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node*next;
};

int main()
{
    int n,i;
    int m,x;
    struct node*head,*tail,*p,*q;
    while(~scanf("%d",&n))
    {
        head=(struct node*)malloc(sizeof(struct node));
        head->next=NULL;
        tail=head;
        while(n--)
        {
            scanf("%d%d",&m,&x);
            i=0;
            for(p=head->next; p!=NULL; p=p->next)
            {
                i++;
            }
            if(m>=i)
            {
                p=(struct node*)malloc(sizeof(struct node));
                p->data=x;
                p->next=NULL;
                tail->next=p;
                tail=p;
            }
            else
            {
                i=-1;//如果m=0,就要在head后面插入节点
                for(p=head;p!=NULL;p=p->next)
                {
                    i++;
                    if(i==m)
                    {
                        q=(struct node*)malloc(sizeof(struct node));
                        q->data=x;
                        q->next=p->next;
                        p->next=q;
                        break;
                    }
                }
            }
        }
        for(p=head->next; p!=NULL; p=p->next)
        {
            if(p->next==NULL)
                printf("%d\n",p->data);
            else
                printf("%d ",p->data);
        }
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值