We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?
Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.
1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.
Output
For each test case, please output “YES
” if it is almost sorted. Otherwise, output “NO
” (both without quotes).
Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO
分析
求出所给序列中最长的上升序列的长度即可,注意这儿的最长上升序列可以是不连续的,如果长度大于等于n-1,就符合题意,否则NO
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100001;
int num[maxn],l_num[maxn],keep[maxn],ans[maxn];
int n;
int research(int _size,int a)
{
int last=0,right=_size-1;
int mid;
while(last<=right)
{
mid=(last+right)>>1;
if(a>=keep[mid-1]&&a<keep[mid])
return mid;
else if(a<keep[mid])
right=mid-1;
else
last=mid+1;
}
}
int LIS(const int *a)
{
ans[0]=1;
keep[0]=a[0];
int k,_size=1;
for(int i=1;i<n;i++)
{
if(a[i]<keep[0])
k=0;
else if(a[i]>=keep[_size-1])
k=_size++;
else
k=research(_size,a[i]);
keep[k]=a[i];
ans[i]=k;
}
return _size;
}
int main()
{
int T;
cin>>T;
while(T--)
{
cin>>n;
memset(ans,0,sizeof(ans));
memset(keep,0,sizeof(keep));
for(int i=0;i<n;i++)
{
scanf("%d",&num[i]);
l_num[n-i-1]=num[i];
}
if(LIS(num)>=n-1||LIS(l_num)>=n-1)
cout<<"YES\n";
else
cout<<"NO\n";
}
}