Frogger POJ - 2253 (求每条路径中最大值的最小值,Dijkstra变形)

Time Limit: 1000MS 

Memory Limit: 65536K

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意与思路:

就是让你求从0到1的路径所经过的最大权值的最小值

用Dijkstra的变形,每个路径的长度是这条路径所经过的最大权值;见代码(1)

也可以用floyed来求;见代码(2)

相似题目是求的求到n点的所有路径中最小权值的最大值。地址链接:https://cn.vjudge.net/problem/11758/origin

代码如下:

(1)

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int n,t=1,sum,mi,u;
int e[220][220],dis[220],book[220],a[1200],b[1200];
void Dijk()
{
    for(int i=0; i<n; i++)//初始化
    {
        dis[i]=e[0][i];
        book[i]=0;
    }
    book[0]=1;//标记
    sum=0;
    while(1)
    {
        mi=inf;
        for(int i=0; i<n; i++)
            if(book[i]==0&&dis[i]<mi)
            {
                mi=dis[i];
                u=i;
            }
        book[u]=1;
        if(sum<mi)//如果小于则更新最大值
            sum=mi;
        if(u==1)//如果找到终点,跳出循环输出
            break;
        for(int i=0; i<n; i++)
            if(book[i]==0&&dis[i]>e[u][i])
                dis[i]=e[u][i];
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(e,inf,sizeof(e));
        for(int i=0; i<n; i++)
            scanf("%d %d",&a[i],&b[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                if(i==j)
                    e[i][j]=0;
                else
                    e[i][j]=(a[j]-a[i])*(a[j]-a[i])+(b[j]-b[i])*(b[j]-b[i]);//各边权值
            }
        Dijk();//用Dijkstra来求,函数调用
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",t++,sqrt(1.0*sum));
        //因为上面权值是求的平方,所以最后开平方输出
    }
    return 0;
}

(2)

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,t=1;
int e[220][220],a[1200],b[1200];
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%d %d",&a[i],&b[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                if(i==j)
                    e[i][j]=0;
                else
                    e[i][j]=(a[j]-a[i])*(a[j]-a[i])+(b[j]-b[i])*(b[j]-b[i]);
            }
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                for(int k=0;k<n;k++)
                    e[j][k]=min(e[j][k],max(e[j][i],e[i][k]));//不断更新路径最大值的最小值
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",t++,sqrt(e[0][1]));//求0到1的
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值