Ice_cream's world I HDU - 2120 (并查集判断环)

Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world.
But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input

8 10

0 1

1 2

1 3

2 4

3 4

0 5

5 6

6 7

3 6

4 7

Sample Output

3

题意与思路:

就是分割土地,一堵墙包围的土地必须只给一个ACMer,问最多能围成的土地,其实就是求能形成多少个环

是判断有几个环,我们就用并查集来求

代码如下:

#include<stdio.h>
#include<string.h>
int sum,n,m,a,b;
int f[1200];
int getf(int v)//并查集
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);//压缩路径
        return f[v];
    }
}
void merge(int v,int u)
{
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2)        //进行并一起,但是这里如果满足相等就证明这里形成一个环
        f[t2]=t1;
    else
        sum++;
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        sum=0;
        for(int i=0; i<n; i++)//初始化
            f[i]=i;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&a,&b);
            merge(a,b);    //调用并查集
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值