poj1159 Palindrome

poj1159 Palindrome

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 68871 Accepted: 23964
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.
Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input

5
Ab3bd
Sample Output

2

比较经典的一道动态规划题,状态转移方程容易寻找:
dp[i][j]=min(dp[(i+1)][j],dp[i][j-1])+1;
可以这样理解,dp[i][j]表示第i个字符到第j个字符边为回文串所需最少操作步数
当s[i] == s[j] 很明显dp[i][j] = dp[i+1][j-1]
当s[i]!=s[j] 可以在i处插入s[j],也可以在j处插入s[i],则有状态转移方程
dp[i][j]=min{dp[i+1][j]+1,dp[i][j-1]+1};
附上AC代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

#define MAXN 5005

short dp[MAXN][MAXN];
char str[MAXN];

int main(){

    int N;
    int i,j;

    while(~scanf("%d",&N)){
        scanf("%s",str);

        memset(dp,0,sizeof(dp));

        for(i=N-1;i>=0;--i){
            dp[i][i]=0;
            for(j=i+1;j<N;++j){
                if(str[i]==str[j]){
                    dp[i][j]=dp[i+1][j-1];
                }
                else{
                    dp[i][j]=min(dp[i+1][j],dp[i][j-1])+1;
                }
            }
        }

        printf("%d\n",dp[0][N-1]);
    }

    return 0;
}

当然,很明显,根据状态转移方程也可以用滚动数组进行空间复杂度优化

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

#define MAXN 5005

short dp[2][MAXN];//滚动数组
char str[MAXN];

int main(){

    int N;
    int i,j;

    while(~scanf("%d",&N)){
        scanf("%s",str);

        memset(dp,0,sizeof(dp));

        for(i=N-1;i>=0;--i){
            dp[i%2][i%2]=0;
            for(j=i+1;j<N;++j){
                if(str[i]==str[j]){
                    dp[i%2][j]=dp[(i+1)%2][j-1];
                }
                else{
                    dp[i%2][j]=min(dp[(i+1)%2][j],dp[i%2][j-1])+1;
                }
            }
        }

        printf("%d\n",dp[0][N-1]);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值