POJ1159——Palindrome

175 篇文章 0 订阅
Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 53647 Accepted: 18522

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000

问你加入多少字符使得字符串变成回文串

我们对字符串和他的逆序串求一个最长公共子序列,这样一来,LCS里的一定是回文的,而其他的一定不会回文,所以必须在相应位置插入那些字符使得他们对称,最后整个串才可以回文

#include <map>    
#include <set>    
#include <list>    
#include <stack>    
#include <queue>    
#include <vector>    
#include <cstdio>    
#include <cmath>    
#include <cstring>    
#include <iostream>    
#include <algorithm>    
    
using namespace std;

char str1[5010];
char str2[5010];
int dp[2][5010];

int main()
{
	int len;
	while (~scanf("%d", &len))
	{
		scanf("%s", str1);
		for (int i = 0; i < len; i++)
		{
			str2[i] = str1[len - i - 1];
		}
		str2[len] = '\0';
		memset (dp, 0, sizeof(dp) );
		for (int i = 1; i <= len; i++)
		{
			for (int j = 1; j <= len; j++)
			{
				if (str1[i - 1] == str2[j - 1])
				{
					dp[i % 2][j] = dp[(i - 1) % 2][j - 1] + 1;
				}
				else
				{
					dp[i % 2][j] = max(dp[(i - 1) % 2][j], dp[i % 2][j - 1]);
				}
			}
		}
		printf("%d\n", len - dp[len % 2][len]);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值