Codeforce 1104B 字符串思维题 类回文(栈)

Game with string
TimeLimit:1000MS MemoryLimit:256MB
64-bit integer IO format:%I64d
已解决 | 点击收藏
Problem Description
Two people are playing a game with a string s, consisting of lowercase latin letters.

On a player’s turn, he should choose two consecutive equal letters in the string and delete them.

For example, if the string is equal to “xaax” than there is only one possible turn: delete “aa”, so the string will become “xx”. A player not able to make a turn loses.

Your task is to determine which player will win if both play optimally.

Input
The only line contains the string s, consisting of lowercase latin letters (1 ≤ |s| ≤ 100 000), where |s| means the length of a string s.

Output
If the first player wins, print “Yes”. If the second player wins, print “No”.

SampleInput 1
abacaba
SampleOutput 1
No
SampleInput 2
iiq
SampleOutput 2
Yes
SampleInput 3
abba
SampleOutput 3
No

Note

In the first example the first player is unable to make a turn, so he loses.

In the second example first player turns the string into “q”, then second player is unable to move, so he loses.

题意:两人轮流消去字符串中的两个相邻的相同字符,字符删去后其他字符后自动连接 即 axxa 删去xx后变成 aa 哪一方无法操作哪一方就输
思路:一般这种类回文的题目可以想到用栈来解

#include <iostream>
#include <stack>

using namespace std;

int main()
{
    string s;

    cin >> s;

    stack<char>st;

    int cnt=0;

    for(int i=0;i<s.length();i++)
    {
        if(!st.empty()&&s[i]==st.top())///相同就弹出
        {
            cnt++;
            st.pop();
        }
        else
            st.push(s[i]);
    }

    if(cnt%2==0)
        cout << "No" << endl;
    else
        cout << "Yes" <<endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值