矩阵快速幂总结

矩阵快速幂整理总结

POJ 3070 Fibonacci

链接

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
1
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
2
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
3

矩阵快速幂模板题。下面的代码可以当做模板用。
Code:

#include <bits/stdc++.h>
#define IO ios::sync_with_stdio(false), cin.tie(0), cout.tie(0);
using namespace std;
typedef long long ll;
const int mod = 10000;

struct Matrix
{
	int mat[2][2];
	Matrix() {}
	Matrix operator*(Matrix const &b) const		//重载操作符* 矩阵相乘
	{
		Matrix res;
		memset(res.mat, 0, sizeof(res.mat));
		for (int i = 0; i < 2; i++)
			for (int j = 0; j < 2; j++)
				for (int k = 0; k < 2; k++)
					res.mat[i][j] = (res.mat[i][j] + this->mat[i][k] * b.mat[k][j]) % mod;	//题目中要求取模,所以加mod
		return res;
	}
};
Matrix pow_mod(Matrix base, int n)		//矩阵快速幂,与快速幂相似
{
	Matrix res;
	memset(res.mat, 0, sizeof(res.mat));
	for (int i = 0; i < 2; i++)
		res.mat[i][i] = 1;
	while (n)
	{
		if (n & 1)
			res = res * base;	//把快速幂中的乘法换成了矩阵乘法
		base = base * base;
		n >>= 1;
	}
	return res;
}
int main()
{
	IO;
	Matrix base;	//常数矩阵
	base.mat[0][0] = base.mat[0][1] = base.mat[1][0] = 1;
	base.mat[1][1] = 0;
	int n;
	while (cin >> n)
	{
		if (n == -1)
			break;
		Matrix ans = pow_mod(base, n);
		cout << ans.mat[1][0] << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值