POJ - 1328 Radar Installation(区间贪心)

POJ - 1328 Radar Installation

vjudge链接:[https://vjudge.net/problem/POJ-1328](https://vjudge.net/problem/POJ-1328)

Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

思路:

 

区间贪心。感觉这个题很巧妙。对每个岛,计算出雷达可以覆盖的范围,然后就转化成了区间的覆盖问题。

按左端点值从小到大排序,然后需要考虑下面两种情况,左端点已经是有序的了,右端点应该要记录的是最小值temp(对应代码第50行),如果temp小于当前区间的左端点,那么一定是有覆盖的范围的,否则说明当前区间与之前的区间没有覆盖范围了,需要新增加一个雷达。

Code:

#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn = 1e3 + 5;
struct point
{
    double x, y;
} a[maxn];
struct edge
{
    double l, r;
} b[maxn];

bool cmp(edge &A, edge &B) { return A.l == B.l ? A.r < B.r : A.l < B.l; } //这里也可以直接写return A.l < B.l;

int main()
{
    int T = 0, n;
    double d;
    while (scanf("%d%lf", &n, &d) != EOF && n)
    {
        double dd = d * d, temp;
        bool flag = false;
        for (int i = 0; i < n; i++)
        {
            scanf("%lf%lf", &a[i].x, &a[i].y);
            if (a[i].y > d)
                flag = true;
        }
        printf("Case %d: ", ++T);
        if (flag)
        {
            printf("-1\n");
            continue;
        }
        for (int i = 0; i < n; i++)
        {
            temp = sqrt(dd - a[i].y * a[i].y);    //求每个岛的覆盖范围
            b[i].r = a[i].x + temp;
            b[i].l = a[i].x - temp;
        }
        sort(b, b + n, cmp);
        int ans = 1;
        temp = b[0].r;
        for (int i = 1; i < n; i++)
        {
            if (temp >= b[i].l)
                temp = min(temp, b[i].r);    //这里min很重要
            else
                temp = b[i].r, ans++;        //增加一个新的雷达
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值