poj1741 Tree (点分治)

Tree

Give a tree with n vertices,each edge has a length(positive integer less than 1001).
Define dist(u,v)=The min distance between node u and v.
Give an integer k,for every pair (u,v) of vertices is called valid if and only if dist(u,v) not exceed k.
Write a program that will count how many pairs which are valid for a given tree.

Input

The input contains several test cases. The first line of each test case contains two integers n, k. (n<=10000) The following n-1 lines each contains three integers u,v,l, which means there is an edge between node u and v of length l.
The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

5 4
1 2 3
1 3 1
1 4 2
3 5 1
0 0

Sample Output

8

题意:

给一棵n个顶点的树,就树上距离小于等于k的点对个数

思路:

点分治
计数的时候不能n2枚举,tle
用了排序+双指针,代码里面有注释

ps:
还学会了一种很优雅的代码写法

code:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
using namespace std;
const int maxm=1e4+5;
struct mp{
    int v,w;
    mp(int vv,int ww){
        v=vv,w=ww;
    }
};
vector<mp>g[maxm];
int mark[maxm];
int sz[maxm],son[maxm];
vector<int>d;
int n,k;
int size,root;
int ans=0;
void init(){
    for(int i=0;i<maxm;i++){
        g[i].clear();
        mark[i]=0;
    }
    ans=0;
}
void getroot(int x,int fa){
    sz[x]=1;
    son[x]=0;
    int len=g[x].size();
    for(int i=0;i<len;i++){
        int v=g[x][i].v;
        if(mark[v]||v==fa)continue;
        getroot(v,x);
        sz[x]+=sz[v];
        son[x]=max(son[x],sz[v]);
    }
    son[x]=max(son[x],size-sz[x]);
    if(son[x]<son[root]){
        root=x;
    }
}
void getd(int x,int val,int fa){
    d.push_back(val);
    int len=g[x].size();
    for(int i=0;i<len;i++){
        int v=g[x][i].v;
        int w=g[x][i].w;
        if(mark[v]||v==fa)continue;
        getd(v,val+w,x);
    }
}
int solve(int x,int val){
    d.clear();
    getd(x,val,0);
    sort(d.begin(),d.end());
    int sum=0;
    int l=0,r=d.size()-1;
    while(l<r){
        if(d[l]+d[r]<=k){//如果成立则任意l+1<=x<=r都满足d[l]+d[x]<=k,答案累加(r-l+1)-1,区间长度减去左端点
            sum+=r-l;
            l++;//左端点右移
        }else{//如果不满足则大的减少
            r--;//右端点左移
        }
    }
    return sum;
}
void divide(int x){
    mark[x]=1;
    ans+=solve(x,0);
    int len=g[x].size();
    for(int i=0;i<len;i++){
        int v=g[x][i].v;
        int w=g[x][i].w;
        if(mark[v])continue;
        ans-=solve(v,w);
        son[root=0]=size=sz[v];
        getroot(v,0);
        divide(root);
    }
}
signed main(){
    while(scanf("%d%d",&n,&k)==2){
        if(n==0&&k==0)break;
        init();
        for(int i=1;i<n;i++){
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            g[a].push_back(mp(b,c));
            g[b].push_back(mp(a,c));
        }
        son[root=0]=size=n;
        getroot(1,0);
        divide(root);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值