Thanks to a certain “green” resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water’s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of ‘#’ represents an oily cell, and a character of ‘.’ represents a pure water cell.
Output
For each case, one line should be produced, formatted exactly as follows: “Case X: M” where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
Sample Input
1
6
…
.##…
.##…
…#.
…##
…
Sample Output
Case 1: 3
题意:
海上漂浮着一些符号为#的石油,你要去搜集他们,但是你的勺子呢能且只能挖到两个单元的石油。问你最多能挖多少勺。注意 不能挖到纯净的海水,不然石油会被纯净的海水稀释的。
找到#的位置,然后用二分图连接起来,再除以2
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=710;
const int INF=0x3f3f3f3f3f;
int line[N][N],girl[N],used[N];
int mp[N][N];
char s[N][N];
int m;
bool found(int x)
{
for(int i=1; i<=m; i++)
{
if(line[x][i]&&!used[i])
{
used[i]=1;
if(girl[i]==0||found(girl[i]))
{
girl[i]=x;
return true;
}
}
}
return false;
}
int match()
{
int sum=0;
memset(girl,0,sizeof(girl));
for(int i=1; i<=m; i++)
{
memset(used,0,sizeof(used));
if(found(i))
sum++;
}
return sum/2;
}
int main()
{
int T;
scanf("%d",&T);
int Case=1;
while(T--)
{
memset(line,0,sizeof(line));
memset(s,0,sizeof(s));
memset(mp,0,sizeof(mp));
int n;
scanf("%d",&n);
getchar();
int tmp=0;
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
{
scanf("%c",&s[i][j]);
if(s[i][j]=='#')
{
mp[i][j]=++tmp;
}
}
getchar();
}
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
{
if(s[i][j]=='#')
{
if(s[i+1][j]=='#')
line[mp[i][j]][mp[i+1][j]]=1;
if(s[i-1][j]=='#')
line[mp[i][j]][mp[i-1][j]]=1;
if(s[i][j+1]=='#')
line[mp[i][j]][mp[i][j+1]]=1;
if(s[i][j-1]=='#')
line[mp[i][j]][mp[i][j-1]]=1;
}
}
}
m=tmp;
printf("Case %d: %d\n",Case++,match());
}
return 0;}