[线段树] POJ 3468 A Simple Problem with Integers

题目

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.

解题思路:一道线段树的模板题,涉及到了区间修改和区间查询,比较容易出错的是定义结构体时要开long long,不然会wa。
以下是ac代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

typedef long long LL;

#define maxx 100005

int n,q;
LL a[maxx];
char t[8];
int l,r;
int s;
LL ans,x;

struct Node {
	LL l,r,w,f;
}tree[maxx*4];

void build(int k, int ll ,int rr) {
	tree[k].l=ll, tree[k].r=rr;
	if(tree[k].l==tree[k].r) {
		tree[k].w=a[s++];
		return;
	}
	int mid=(ll+rr)/2;
	build(k*2,ll,mid);
	build(k*2+1,mid+1,rr);
	tree[k].w=tree[k*2].w+tree[k*2+1].w;
}

void down(int k) {
	tree[k*2].f+=tree[k].f;
	tree[k*2+1].f+=tree[k].f;
	tree[k*2].w+=tree[k].f*(tree[k*2].r-tree[k*2].l+1);
	tree[k*2+1].w+=tree[k].f*(tree[k*2+1].r-tree[k*2+1].l+1);
	tree[k].f=0; 
}

void ask(int k) {
	if(tree[k].l>=l && tree[k].r<=r) {
		ans+=tree[k].w;
		return;
	}
	if(tree[k].f) down(k);
	int m=(tree[k].l+tree[k].r)/2;
	if(l<=m) ask(k*2);
	if(r>m) ask(2*k+1);
}

void add(int k) {
	if(tree[k].l>=l && tree[k].r<=r) {
		tree[k].w+=(tree[k].r-tree[k].l+1)*x;
		tree[k].f+=x;
		return;
	}
	if(tree[k].f) down(k);
	int m=(tree[k].l+tree[k].r)/2;
	if(l<=m) add(2*k);
	if(r>m) add(2*k+1);
	tree[k].w=tree[k*2].w+tree[k*2+1].w;
}

int main() {
	scanf("%d %d",&n,&q);
	
	for(int i=1;i<=n;i++) {
		scanf("%lld",&a[i]);
	}
	
	s=1;
	build(1,1,n);
	
	for(int i=1;i<=q;i++) {
		scanf("%s",t);
		if(t[0]=='Q') {
			scanf("%d %d",&l,&r);
			ans=0;
			ask(1);
			printf("%lld\n",ans);
		} else {
			scanf("%d %d %lld",&l,&r,&x);
			add(1);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值