题目
Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19791 Accepted: 5395
Description
Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.
For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
Input
The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, …, 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output
For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input
1
0 1 2 4 6 7
Sample Output
28
Source
Rocky Mountain 2005
PS.**************************************************************************************************
看了别人的题解之后,发现了一个很好用的输入方式:cin>>skipws>>c>>noskipws>>s ,一般c和s都为char类型的变量,skipws的作用是输入时忽略掉空格和回车符,而noskipws的作用显然是不跳过空格和回车,所以有时候输入一段字符串时,可以用此方法代替getline() (其实是因为我不会/(ㄒoㄒ)/~~),下面贴一下使用方法,input:0 1 2 3 4 ouput:1234。
#include <iostream>
#include <cstdio>
using namespace std;
char a[100];
int main() {
int k=0;
char c, s;
while(cin>>skipws>>c>>noskipws>>s) {
a[k++]=c;
if(s=='\n') break;
}
for(int i=0;i<k;i++) printf("%c",a[i]);
return 0;
}
思路
想法十分简单,用nex_permutation() 对数组进行全排列,每次取一半进行分界,计算两边的差的绝对值。但有一点需要注意下,就是当g[0]==0或者g[size/2]==0时,要判断下左右边各自的总和,如果其中有值不为0,则违反了题目的要求。下面贴AC代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
using namespace std;
#define maxx 10
#define inf 0x7fffffff
vector<int> g;
void read() {
g.clear();
char a[50];
cin.getline(a,50);
for(int i=0;a[i]!='\0';i++) {
if(a[i]>='0' && a[i]<='9') {
g.push_back(a[i]-'0');
}
}
}
void solve() {
int ans=inf;
int a,b;
do {
a=0, b=0;
for(int i=0;i<g.size()/2;i++) {
a*=10;
a+=g[i];
}
for(int j=g.size()/2;j<g.size();j++) {
b*=10;
b+=g[j];
}
if((g[0]==0 && a!=0) || (g[g.size()/2]==0 && b!=0)) continue;
ans=min(ans,abs(a-b));
} while(next_permutation(g.begin(),g.end()));
printf("%d\n",ans);
}
int main() {
int n;
scanf("%d",&n);
getchar();
for(int i=0;i<n;i++) {
read();
solve();
}
return 0;
}