Problem C 用setw、cout和for循环编写程序打印图形

Problem Description

拟用setw、cout和for循环编写程序,打印输出“输出样例”中的图形。请完善下面的程序:
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{   
    int n;    
    //你的代码将被嵌在这里       
    return 0;
}

Input Description

从键盘录入一个正整数n,用于表示输出图形的行数

Output Description

按格式输出n行星号图形

Sample Input

4

Sample Output

   *
  ***
 *****
*******
cin >> n;
    int x,y ;
    for (int i = 1, j = n; i <= n; i++, j--)
    {
        cout << setw(j);
        x = i;
        y = i;
        while (x--)//x次循环
        {
            cout << "*";
        }
        while (--y)//x-1次循环
        {
            cout << "*";
        }
        cout << "\n";
    }

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值