B - *e**** ********e* *e****e* ****e**

Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 200 points

Problem Statement
You are given a string S of length N consisting of lowercase English letters, and aninteger K. Print the string obtained by replacing every character in S that differs from the K-thcharacter of S, with *.Constraints1≤K≤N≤10S is a string of length N consisting of lowercase English letters.N and K are integers.

Input
Input is given from Standard Input in the following format:

N S K

Output
Print the string obtained by replacing every character in S that differs from the -th character of S, with *.

Sample Input 1
5
error
2
Sample Output 1
rrr

The second character of S is r. When we replace every character in error that differs from r with *, we get the string rrr.

Sample Input 2
6
eleven
5
Sample Output 2
eee*
Sample Input 3
9
education
7
Sample Output 3
****i

把字符串的和第k个字符相同的保存,其他的变成*

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<ctime>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<vector>
#define ll long long
#define dd double
using namespace std;

int main() {
	ll n;
	string s;
	ll m;
	while (cin >> n) {
		cin >> s;
		cin >> m;
		char x = s[m - 1];
		for (ll i = 0; i < s.size(); i++) {
			if (s[i] != x) {
				cout << '*';
			}
			else {
				cout << s[i];
			}
		}
		cout << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值