Rng HDU-6574

Rng

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 454    Accepted Submission(s): 294


 

Problem Description
Avin is studying how to synthesize data. Given an integer n, he constructs an interval using the following method: he first generates a integer r between 1 and n (both inclusive) uniform-randomly, and then generates another integer l between 1 and r (both inclusive) uniform-randomly. The interval [l, r] is then constructed. Avin has constructed two intervals using the method above. He asks you what the probability that two intervals intersect is. You should print p* q(−1)(MOD 1, 000, 000, 007), while pq denoting the probability.
 

 

Input
Just one line contains the number n (1 ≤ n ≤ 1, 000, 000).
 

 

Output
Print the answer.
 

 

Sample Input
 
1 2
 

 

Sample Output
 
1 750000006
 

 

Source

 

读题的时候在想,咋求个概率还能怼出来大于一的数,后来知道是求逆元,还是太菜.

思路:图片来自:https://www.cnblogs.com/sstealer/p/11250734.html

然后求逆元即可.

我的代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;

const ll mod = 1000000007;

ll qsm(ll a,ll b)
{
	ll ans=1;
	while(b)
	{
		if(b & 1) ans=ans*a%mod;
		b>>=1;
		a=a*a%mod;
	}
	return ans;
}

int main()
{
	ll n;
	while(cin>>n)
	{
		cout<<(n+1)*qsm(n*2,mod-2)%mod<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值