【王道机试】排序模板+运算符重载

排序模板sort

包含在头文件#include<algorithm>
使用命名空间:using namespace std;
函数:sort(a,a+n),其中a是起始位置,a+n是结束地址。默认是正序排序(即从小到大排序)
若想逆序排序,则需要重新定义运算规则:sort(a,a+n,cmp)
其中cmp函数定义:

bool cmp(int a,int b)
{
	return a>b;
}

在这里插入图片描述
输入样例

3
abc 20 99
bcd 19 97
bed 20 97

输出样例

bcd 19 97
bed 20 97
abc 20 99

针对这种学生信息的问题,首先应该想到用结构体来封装各个属性:

struct Student
{
	char name[101];
	int age,score;
}buf[1000];

其次,因为它不仅仅存在对分数的排序,当分数相同时,还要比较姓名、年龄。所以我们在这里重新定义一个小于运算符
其中有两种方法:

  1. 在结构体中重载小于运算符:(关于重载运算符详细说明,可以参考菜鸟教程
 bool operator < (const student &b) const{
     	if(score!=b.score) return score<b.score;
     	int tmp = strcmp(name,b.name);//Greater:1 ,Less:-1, Equal:0
     	if(tmp!=0)//姓名不一样时
     		return tmp<0;
     	else return age<b.age;
     	}
		调用时:sort(a,a+n);
  1. cmp函数定义
bool cmp(struct student &a,struct student &b)
{
	if(a.score!=b.score)	return a.score<b.score;
	int tmp = strcmp(a.name,b.name);
	if(tmp!=0)
		return tmp<0;
	else	return a.age<b.age;
 } 
调用时:sort(a,a+n,cmp);

代码如下

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;

struct student{
	char name[101];
	int age,score;
	bool operator < (const student &b) const{
		if(score != b.score)	return score<b.score;
		int tmp = strcmp(name,b.name);
		if(tmp!=0)
			return tmp<0;
		else
			return age<b.age;
		}
}buf[1001];
bool cmp(struct student &a,struct student &b)
{
	if(a.score!=b.score)	return a.score<b.score;
	int tmp = strcmp(a.name,b.name);
	if(tmp!=0)
		return tmp<0;
	else	return a.age<b.age;
 } 
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%s %d%d",buf[i].name,&buf[i].age,&buf[i].score); 
		}
	//	sort(buf,buf+n,cmp);//定义cmp函数时 
		sort(buf,buf+n);//定义重载运算符时 
		for(int i=0;i<n;i++)
		{
			printf("%s %d %d\n",buf[i].name,buf[i].age,buf[i].score);
		}
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值