POJ - 2253 Frogger

POJ - 2253 Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意描述:给出n快石头的坐标,计算从第一块石头跳到第二块石头需要最小跳跃极限是多少,比如从1到3是3米,3到2是2米,1到2是5米,那么这个距离为3米,求出一条路线的中跳跃的最大距离,是所有路线最大跳跃距离中的最小值。
解题思路:Dijkstra模板,只是最后缩短路径的时候有一点改变,求出中间点到源点和目标点到中间点的最大值和中间点相比中的最小值赋到目标点的dis数组中。
注意事项:注意dis数组存和储存距离的数组开为double类型就可以,注意输出格式。

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 9999999
int a[400],b[400],c[400];
double e[400][400],dis[400];
int main()
{
    int n,xiao,u,v,i,j,l=1;
    while(scanf("%d",&n),n!=0)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                e[i][j]=sqrt((double)(a[j]-a[i])*(a[j]-a[i])+(b[j]-b[i])*(b[j]-b[i]));
            }
        }
        for(i=1;i<=n;i++)
        {
            dis[i]=e[1][i];
        }
        for(i=1;i<=n;i++)
        {
            c[i]=0;
        }
        b[1]=1;
        for(i=1;i<n;i++)
        {
            xiao=9999999;
            for(j=1;j<=n;j++)
            {
                if(c[j]==0&&dis[j]<xiao)
                {
                    xiao=dis[j];
                    u=j;
                }
            }
            c[u]=1;
            for(v=1;v<=n;v++)
            {
                dis[v]=min(dis[v],max(e[u][v],dis[u]));
            }
        }
        printf("Scenario #%d\n",l++);
        printf("Frog Distance = %.3f\n\n",dis[2]);
    }
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值