王道机试复试指南---第七章---7.2区间贪心

7.2区间贪心

今年暑假不AC

#include<iostream>
#include<cstdio>
#include<algorithm>
const int MAXN=100;

using namespace std;

struct video{
	int s;
	int e;
}v[MAXN];

bool cmp(video x,video y){
	return x.e<y.e;
}

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		if(n==0){
			break;
		}
	
		for (int i=0;i<n;i++){
			scanf("%d%d",&v[i].s,&v[i].e);
		}
		int sum=0;
		sort(v,v+n,cmp);
		int current=0;
		for(int i=0;i<n;i++){
			
			if(current<=v[i].s){
				sum++;
				current=v[i].e;
			}
		}
		printf("%d\n",sum);		
			
	}
		
	return 0;
	
}

POJ 1328 Radar Installation
Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 76845 Accepted: 17213
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>

using namespace std;

const int MAXN=1000+10;

struct Interval{		//记录相交情况下的左右区间 
	double left;
	double right;
};

Interval arr[MAXN];
bool Compare(Interval a,Interval b){
	return a.left<b.left;
}

int main(){
	int n,d;		//岛屿数目,雷达半径
	int caseNumber=0;
	while(scanf("%d%d",&n,&d)!=EOF){
		if(n==0&&d==0){
			break;
		}
		bool flag=true;
		for(int i=0;i<n;i++){
			int x,y;
			scanf("%d%d",&x,&y);
			if(y>d){
				flag=false;
			}else{
				arr[i].left=x-sqrt(d*d-1.0*y*y);
				arr[i].right=x+sqrt(d*d-1.0*y*y);
			}
		}
		if(!flag){
			printf("Case %d: %d\n",++caseNumber,-1);
		}else{
			sort(arr,arr+n,Compare);
			double current=arr[0].right;
			int answer=1;
			for(int i=1;i<n;++i){
				if(arr[i].left<=current){
					current=min(current,arr[i].right);
				}else{
					current=arr[i].right;
					answer++;
				}
			}
			printf("Case %d: %d\n",++caseNumber,answer);
		}
	} 	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Miraitowa_FTY

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值