PAT甲级---1005 Spell It Right (20 分)

该程序旨在读取一个不超过10^100的非负整数,计算其所有数字之和,然后将这个和的每个数字转换为英文单词输出。示例输入为12345,输出应为'onefive'。提供的参考代码可能无法编译,因为它直接将字符串转换后的数字与预定义的英文数字数组进行比较并输出。
摘要由CSDN通过智能技术生成

PAT甲级—1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10
100
).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

#include<iostream>
#include<cstring>
#include<string>
using namespace std;

string c[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};

int main(){
	char a[105];
	while(gets(a))
	{
		int len=strlen(a);
		int sum=0;
		for(int i=0;i<len;i++){
			sum+=a[i]-'0';
		}
		
		string b=to_string(sum);
		
		int len2=b.length();
		for(int i=0;i<len2;i++){
			printf("%s",c[b[i]]);
		}
	}
	
	return 0;
}

无法编译,原因未知
参考答案

#include <iostream>
using namespace std;
int main() {
    string a;
    cin >> a;
    int sum = 0;
    for (int i = 0; i < a.length(); i++)
        sum += (a[i] - '0');
    string s = to_string(sum);
    string arr[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    cout << arr[s[0] - '0'];
    for (int i = 1; i < s.length(); i++)
        cout << " " << arr[s[i] - '0'];
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Miraitowa_FTY

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值