Ride to School HDU - 1445

Ride to School

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus - Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except “Charley” ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit - he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample input

4
20 0
25 -155
27 190
30 240
2
21 0
22 34
0

Sample output

780
771

解题思路:

  1. 这个痴汉是只要他前面有有比他跟着的人的速度快得,那么一定会改变跟着的人。
  2. 也就是说这个痴汉跟的人一定到最后一定是比所有人的所用时间都短。
  3. 这个时间的计算是总路程除以速度加出门时间。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>//这个是一定要要的,具体下面会有解释
using namespace std;
int main()
{
	 int n;//首先定义一个n,代表有n个速度以及出门时间
	 while(cin>>n){
	 	if(n==0)break;
	 	int a,b,sum=0x7fffffff,v;
	 	for(int i=0;i<n;i++){
	 		cin>>a>>b;
	 		if(b<0)continue;
	 		v=(int)ceil(4.5/a*3600)+b;//ceil的调用要有math,ceil的含义是返回大于或者等于指定表达式的最小整数。PS:注意速度是千米每小时,而时间的单位是秒
	 		if(sum>v){//用sum取出最小值
	 			sum=v;
			 } 
		 }
		 cout<<sum<<endl;
	 }
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值