PTA|《C语言程序设计(第3版)》习题11-8 单链表结点删除 (20分)

题目

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:

struct ListNode {
    int data;
    ListNode *next;
};

函数接口定义:

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

struct ListNode {
    int data;
    struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
     struct ListNode *p = L;
     while (p) {
           printf("%d ", p->data);
           p = p->next;
     }
     printf("\n");
}

int main()
{
    int m;
    struct ListNode *L = readlist();
    scanf("%d", &m);
    L = deletem(L, m);
    printlist(L);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

10 11 10 12 10 -1
10

输出样例:

11 12 

参考解答

struct ListNode *readlist(){
    int data;
    struct ListNode *p,*head=NULL,*tail=NULL;
    scanf("%d",&data);
    while(data!=-1){
        if(data>0){
            p=(struct ListNode *)malloc(sizeof(struct ListNode));
            p->data=data;
            if(head==NULL)head=p;
            else tail->next=p;
            tail=p;
        }
        scanf("%d",&data);
    }
    if(tail!=NULL)tail->next=NULL;
    return head;
}
struct ListNode *deletem( struct ListNode *L, int m ){
    struct ListNode *p=L,*head=NULL;
    while(p!=NULL&&p->data==m)p=p->next;
    head=p;
    while(p!=NULL){
        while(p->next!=NULL&&p->next->data==m){
            p->next=p->next->next;
        }
        p=p->next;
    }
    return head;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值