B - kiki's game HDU - 2147

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

5 3
5 4
6 6
0 0

Sample Output

What a pity!
Wonderful!
Wonderful!

最近琪琪没什么事。当她无聊的时候,一个想法出现在他的脑海里,她只是玩棋盘游戏。棋盘的大小是N*M。首先,一枚硬币放在右上角(1,M)。每次一个人可以把硬币移到左边,下面或左下边的空白处。不能移动的人将输掉游戏。

琪琪和zz一起玩。游戏总是从琪琪开始。如果双方都打得很好,谁会赢呢?
输入
输入包含多个测试用例。每行包含两个整数n,m(0<n,m<2000)。当n=0和m=0时,输入终止。
输出
如果kiki赢了游戏输出“Wonderful!”,否则“What a pity!”.

在纸上演算一下很容易找到规律

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <cstring>

using namespace std;

int main(){
	int n,m;
	while(cin >>n>>m && n && m){
		if(n%2==0 || m%2==0)
			printf("Wonderful!\n");
		else 
			printf("What a pity!\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值