题目描述:
Misspelling is an art form that students seem to excel at. Write a program that removes the nth character from an input string.
输入:
The first line of input contains a single integer N, (1 ≤ N ≤ 1000)which is the number of datasets that follow. Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.
输出:
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.
样例输入:
4
4 MISSPELL
1 PROGRAMMING
7 CONTEST
3 BALLOON
样例输出:
1 MISPELL
2 ROGRAMMING
3 CONTES
4 BALOON
解题思路:
输入一个数n,随之输入n行,每行第一个数是整数m,第二个数是单词a,每行的整数代表删掉该行单词的第几个字母。用一个for循环单词,当下标不等于m-1时,直接输出当前字母,否则跳过。
参考代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n,m,i;
int t=0;
while(cin>>n){
while(n--){
char a[85];
cin>>m>>a;
t++;
cout<<t<<" ";
int len=strlen(a);
for(i=0;i<len;i++){
if(i==m-1)
continue;
else
cout<<a[i];
}
cout<<endl;
}
}
return 0;
}