HDU3374 String Problem

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input
Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input
abcder
aaaaaa
ababab

Sample Output
1 1 6 1
1 6 1 6
1 3 2 3

这个题让求所给字符串如abcder,每次把第一个字母移动到最后,
1–abcder
2–bcdera
3–cderab
4–derabc
5–erabcd
6–rabcde
求按字典序,最小(abcder)和最大(rabcde)出现的位置和次数。

我们可以利用kmp算法中的next数组和最大最小表示法来求。

求次数,就是看所给字符串的循环情况,我们利用next数组性质来求。

对于next数组中的i,符合i%(i-next[i])==0&&next[i]!=0的情况下,循环节长度为i-next[i],循环次数为i/(i-next[i])。

然后,对最大最小表示法的理解(以最小表示法为例):找字符串中最小字符的位置。如果(i+k)%len位置上的字符小于j位置上的字符,就把j的字符后移j+k+1,
如果大于,就将i后移。orz我再想想

然后,代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[1000010];
int Next[1000010];//用next在提交时编译错误orz
void getNext(int len)// 对Next数组赋值
{
int i=0,j=-1;
Next[0]=-1;
while(i<len)
{
	if(j==-1||str[i]==str[j])
	{
		i++;
		j++;
		Next[i]=j;
	}
	else
	j=Next[j];
}
}
int getmin(int len)/*如果是abcder的话,a开头的字符串对应1,b开头的字符串对应2……
                               r开头的字符串对应6*/
{
int i=0,j=1,k=0;
int t;
while(j<len&&i<len&&k<len)
{
	t=str[(i+k)%len]-str[(j+k)%len];/*比较字符的大小。(i=0,j=1,k=0即比较第一个
	和第 二个字符大小),%len是怕超出长度,开个2倍数组或许就不用%len了*/                                
	if(t==0)
	{
		k++;//如果相等,k++,及比较第二个和第三个字符大小
	}
	else
	{
		if(t>0)//如果i位置上的大于j位置上的字符串,可用bbacde模拟一下
		{
			i+=k+1;//i后移k+1个
			k=0;
		}
		else
		{
			j+=k+1;//j后移k+1
			k=0;
		}
		if(i==j)//相等时继续将j后移
		++j;
	}
}
return min(i,j);
}

int getmax(int len)//最大表示法,和最小表示法意思近似
{
int i=0,j=1,k=0;
while(j<len&&i<len&&k<len)
{
	int t=str[(i+k)%len]-str[(j+k)%len];
	if(t==0)
	{
		k++;
	}
	else
	{
		if(t>0)//(i+k)%len位置上的字符串>(j+k)%len位置上的字符串
		{
			j+=k+1;//j后移
		}
		else
		{
			i+=k+1;
		}
		if(i==j)
		j++;
		k=0;
	}
}
return min(i,j);
}
int main()
{
while(scanf("%s",str)!=EOF)
{
	int len=strlen(str);
	getNext(len);
	int num=1;
	int x=len-Next[len];
	if(len%x==0)//利用Next数组性质判断循环及求循环次数
	{
		num=len/x;
	}
	int posmin=getmin(len);
	int posmax=getmax(len);
	printf("%d %d %d %d\n",posmin+1,num,posmax+1,num);
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值