Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
- V’ = V.
- T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
- V’ = V.
- T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!
是否存在多个最小生成树的问题,如果只有一个最小生成树,则输出权值的和,否则输出Not Unique!
思路:先建成最小生成树,然后再把最小生成树的边依次去掉,再寻找一遍是否存在最小生成树。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int N=100000;
//vector<int> del;
int path[N];
int f[110];
int n,m;
struct Edge
{
int u,v,w;
bool operator<(const Edge &W) const{
return w<W.w;
}
}edges[10005];
int find(int x)
{
if(f[x]==x)
return x;
else
{
f[x]=find(f[x]);
return f[x];
}
}
int kruskal()
{
sort(edges,edges+m);//按权值从小到大排序
for(int i=1;i<=n;i++)
{
f[i]=i;
}
int res=0;
int cnt=0;
//int flag=1;
for(int i=0;i<m;i++)
{
int a=edges[i].u,b=edges[i].v,w=edges[i].w;//先生成最小生成树,记录
权值和所经过的路径
a=find(a);
b=find(b);
if(a!=b)
{
res+=w;
//cnt++;
f[a]=b;
path[cnt++]=i;
}
}
//if(cnt==n-1)
//flag=1;
//if(flag)
//{
for(int i=0;i<cnt;i++)
{
int cnt1=0;
int res1=0;
for(int k=1;k<=n;k++)
{
f[k]=k;
}
for(int j=0;j<m;j++)
{
if(path[i]!=j)//如果j不在之前生成树的路径上,则继续更新
{
int a=edges[j].u,b=edges[j].v,w=edges[j].w;
a=find(a);
b=find(b);
if(a!=b)
{
res1+=w;
cnt1++;
f[a]=b;
}
}
}
if(res==res1&&cnt1==n-1)//如果权值相等且cnt1==n-1
{
return -1;
}
}
//}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
// del.clear();
// for(int i=0;i<m;i++)
// {
// edges[i].u=0;
// edges[i].v=0;
// edges[i].w=0;
// }
for(int i=0;i<m;i++)
{
int u,v,w;
scanf("%d %d %d",&edges[i].u,&edges[i].v,&edges[i].w);
}
int k=kruskal();
if(k!=-1)
printf("%d",k);
else
printf("Not Unique!");
if(t)
printf("\n");
}
return 0;
}