Naptime

Goneril is a very sleep-deprived cow. Her day is partitioned into N (3 <= N <= 3,830) equal time periods but she can spend only B (2 <= B < N) not necessarily contiguous periods in bed. Due to her bovine hormone levels, each period has its own utility U_i (0 <= U_i <= 200,000), which is the amount of rest derived from sleeping during that period. These utility values are fixed and are independent of what Goneril chooses to do, including when she decides to be in bed.

With the help of her alarm clock, she can choose exactly which periods to spend in bed and which periods to spend doing more critical items such as writing papers or watching baseball. However, she can only get in or out of bed on the boundaries of a period.

She wants to choose her sleeping periods to maximize the sum of the utilities over the periods during which she is in bed. Unfortunately, every time she climbs in bed, she has to spend the first period falling asleep and gets no sleep utility from that period.

The periods wrap around in a circle; if Goneril spends both periods N and 1 in bed, then she does get sleep utility out of period 1.

What is the maximum total sleep utility Goneril can achieve?
Input

  • Line 1: Two space-separated integers: N and B

  • Lines 2…N+1: Line i+1 contains a single integer, U_i, between 0 and 200,000 inclusive
    Output
    The day is divided into 5 periods, with utilities 2, 0, 3, 1, 4 in that order. Goneril must pick 3 periods.
    Sample Input
    5 3
    2
    0
    3
    1
    4
    Sample Output
    6
    Hint
    INPUT DETAILS:

The day is divided into 5 periods, with utilities 2, 0, 3, 1, 4 in that order. Goneril must pick 3 periods.

OUTPUT DETAILS:

Goneril can get total utility 6 by being in bed during periods 4, 5, and 1, with utilities 0 [getting to sleep], 4, and 2 respectively.

AcWing:https://www.acwing.com/problem/content/290/
大佬讲的很好。
状态转移方程f[1&i(记录小时数)][睡觉时长][是否在睡觉]

#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m;
const int N=4000,INF=0x3f3f3f3f;
int dp[2][N][2];//要用滚动数组,否则数组太大
int w[N];
int main()
{
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
    scanf("%d",&w[i]);
}
memset(dp,-0x3f,sizeof dp);
dp[1&1][0][0]=dp[1&1][1][1]=0;//第N个小时没有睡觉
for(int i=2;i<=n;i++)
{
    for(int j=0;j<=m;j++)
    {
        dp[i&1][j][0]=max(dp[(i-1)&1][j][0],dp[(i-1)&1][j][1]);
        if(j)
        dp[i&1][j][1]=max(dp[(i-1)&1][j-1][0],dp[(i-1)&1][j-1][1]+w[i]);
    }
}
int res=max(dp[n&1][m][0],dp[n&1][m][1]);
memset(dp,-0x3f,sizeof dp);
dp[1&1][0][0]=0;//第N个小时在睡觉且第一个小时在睡觉时的状态
dp[1&1][1][1]=w[1];
for(int i=2;i<=n;i++)
{
    for(int j=0;j<=m;j++)
    {
        dp[i&1][j][0]=max(dp[(i-1)&1][j][0],dp[(i-1)&1][j][1]);
        if(j)
        dp[i&1][j][1]=max(dp[(i-1)&1][j-1][0],dp[(i-1)&1][j-1][1]+w[i]);
    }
}
res=max(res,dp[n&1][m][1]);
printf("%d\n",res);
return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值