区间dp(E - Multiplication Puzzle)

题目(E - Multiplication Puzzle )

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10150 + 50205 + 10505 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
15020 + 1205 + 1015 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650

题意:

从紧挨着的三个数相乘后再删掉中间的那个数,第一个与最后一个不能删,把这些乘积相加求其最小。

分析

刚开始想到是区间dp但是不知道如何求解,dp是把一个大问题分成几个小问题。

dp[i][i+len]=min(dp[i][i+len],dp[i][k]+dp[k][i+len]+a[i]*a[k]*a[i+len]);

在i到i+len这个区间中找一个位置为k,则i到i+len这个区间的最小值等于i到i+k区间与k到i+len区间的和再加上整个区间的第一个与最后一个和a[k]的乘积
之所以再加上a[i]*a[k]*a[i+len]
因为左小区间求的是只剩下a[1]与a[k],右小区间求的是剩下a[k]与an,则最后一次相乘即这三个相乘把a[k]去掉。

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
const int inf=0x3f3f3f3f;
int dp[200][200];
int main() {
	int n,a[120];
	int i,j,k,len;
	cin>>n;
	for(i=1; i<=n; i++) {
		cin>>a[i];
	}
	for(len=2; len<n; len++) {
		for(i=1; i+len<=n; i++) {
			dp[i][i+len]=inf;
			for(k=i+1; k<i+len; k++) {
				dp[i][i+len]=min(dp[i][i+len],dp[i][k]+dp[k][i+len]+a[i]*a[k]*a[i+len]);
			}
		}
	}
	cout<<dp[1][n]<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值