PAT A1081 Rational Sum

题目描述

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:
3 1/3

Sample Input 2:
2
4/3 2/3

Sample Output 2:
2

Sample Input 3:
3
1/3 -1/6 1/8

Sample Output 3:
7/24

思路(除个人意见外都摘自葵花宝典)

  1. 这题是简单的关于分数的四则运算,只要认真将有关分数的化简,四则运算,输出的相关代码熟练,即可做出;
  2. 还要注意判断溢出。

代码如下

#include<cstdio>
#include<algorithm>
using namespace std;
int gcd(int a, int b)
{
 if(b == 0) return a;
 else return gcd(b, a % b);
}
struct fraction
{
 int up, down;
}frc[101], sum;
fraction reduction(fraction result)
{
 if(result.down < 0)
 {
  result.up = - result.up;
  result.down = - result.down;
 }
 else if(result.up == 0)
 {
  result.down = 1;
  result.up = 0;
 }
 else
 {
  int d = gcd(abs(result.up), abs(result.down));
  result.up /= d;
  result.down /= d;
 }
 return result;
}
void get_add_fraction(fraction b)
{
 sum.up = sum.up * b.down + b.up * sum.down;
 sum.down = sum.down * b.down;
 sum = reduction(sum);
}
void show_result(fraction a)
{
 a = reduction(a);
 if(a.down == 1) printf("%d", a.up);
 else if(abs(a.up) > a.down)
 {
  printf("%d %d/%d", a.up / a.down, a.up % a.down, a.down);
 }else
 {
  printf("%d/%d", a.up, a.down);
 }
}
int main()
{
 int n;
 scanf("%d", &n);
 sum.down = 1, sum.up = 0;
 for(int i = 0; i < n; i++)
 {
  scanf("%d/%d", &frc[i].up, &frc[i].down);
  frc[i] = reduction(frc[i]);
  get_add_fraction(frc[i]);
 }
 show_result(sum);
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值