Super Jumping! Jumping! Jumping!(01背包)

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

InputInput contains multiple test cases. Each test case is described in a line as follow: N value_1 value_2 …value_N It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. A test case starting with 0 terminates the input and this test case is not to be processed.
OutputFor each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3
题意思路:
求解最大递增子序列和,这里要特别注意一点:这个题目不要求是连续的最大递增子序列。但是一定要注意是递增的!!例如4 6 2 3 4 最后结果是9而不是6.
代码1:

#include<iostream>
using namespace std;
int a[1010],dp[1010];
int main()
{
 int n;
 while(cin>>n&&n!=0)
 {
  int max=0;
  for(int i=1;i<=n;i++)
  {
   cin>>a[i];
   dp[i]=a[i];
     }
  for(int i=1;i<=n;i++)
  for(int j=0;j<i;j++)
  if(a[i]>a[j])
  {
   dp[i]=dp[i]>dp[j]+a[i]?dp[i]:dp[j]+a[i];
         if(max<dp[i])
   max=dp[i];
     }
  cout<<max<<endl;
 }
 }

代码2:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#define MAX 0x3f3f3f3f
using namespace std;
typedef long long ll;
long long num[1111],dp[1111];
int main()
{
 
    int n;
    while(cin >> n && n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            cin >> num[i];
        dp[0]=num[0];
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<i;j++)
            {
                if(num[i]>num[j])
                    dp[i]=max(dp[i],dp[j]+num[i]);
                else
                    dp[i]=max(num[i],dp[i]);
            }
        }
        sort(dp,dp+n);
        cout << dp[n-1] << endl;
    }
    return 0;
}

感悟:背包,真的是需要练习,更要知道怎么用背包,总之要牢记模板。能快速敲出来关键代码。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值