HDU 2669 (扩展欧几里德算法)

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print “sorry” instead.

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.

Sample Input
77 51
10 44
34 79

Sample Output
2 -3
sorry
7 -3

由扩展欧几里得定理有,如果ax+by = d 要使得方程有解必有gcd(a,b)为d的约数。
而此题的d = 1 所以若gcd(a,b)!=1,则应该输出sorry
注意,输出的x应为最小的非负整数,这就需要用到x,y所有解的公式:
x,y所有解:
假设d=gcd(a,b). 那么x=x0+b/dt; y=y0-a/dt;其中t为任意常整数

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define ll long long
#define inf 1000000
using namespace std;
ll exgcd(ll a,ll b,ll &x,ll &y){
    int d=a;
    if(b!=0){
        d=exgcd(b,a%b,y,x);
        y-=(a/b)*x;
    }else{
        x=1;y=0;
    }
    return d;
}
int main(){
    ll a,b,x,y,g;
    while(scanf("%lld %lld",&a,&b)!=EOF){
        g=exgcd(a,b,x,y);
        if(g!=1){
            printf("sorry\n");
        }else{
            if(x<0){
                x=x+b;
                y=y-a;
            }
            printf("%lld %lld\n",x,y);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值