中位数

一个有 n 个整数的数组 a,n是一个奇数。

每次可以选择数组里的一个元素 a​i​​ 并把这个元素加上 1。

在至多 k 次操作之后,数组的中位数最大能变成多少。

输入格式:

多组输入

第一行两个整数 n,k(1≤n≤2×10​5​​,1≤k≤10​9​​)。

第二行 n 和整数 a​1​​,a​2​​,......,a​n​​。

输出格式:

k 次操作后数组的中位数。

输入样例:

3 2
1 3 5

输出样例:

5

首先,用最普通的想法就是从中位数开始往后一个数一个数地找找到可以实现的最大中位数的值;第二种方法用二分法来枚举中位数,看是否可行;这个题注意ai的范围没有说明,可能超过int范围,所以记得用long long

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=2e5+10;
ll a[maxn],b[maxn];
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);
    int n,k;
    while(cin>>n>>k)
    {
        for(int x=1;x<=n;x++)
        {
            cin>>a[x];
        }
        sort(a+1,a+n+1);
        ll z=(n+1)/2;
        for(int x=z;x<n;x++)
        {
            b[x+1]=a[x+1]-a[x];
        }
        ll ans=a[z],w=1;
        while(k>0)
        {
            if(k-b[z+w]*w>=0&&z+w<=n)
            {
                k-=b[z+w]*w;
                //cout<<k<<endl;
                ans=a[z+w];
                w++;
            }
            else
            {
                ans+=k/w;
                break;
            }
        }
        cout<<ans<<endl;
    }
}
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <string>
using namespace std;
#define int long long
int x[200010];
signed main()
{
    int n,k;
    while(~scanf("%d %d",&n,&k))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x[i]);
        }
        sort(x,x+n);
        int l=x[n/2],r=x[n-1]+k/(n/2+1);
        int mid=(l+r)/2;
        //int ans;
        while(l<=r)
        {
            int t=k;
            for(int i=n/2;x[i]<mid && i<n;i++)
            {
                t-=(mid-x[i]);
                if(t<0)
                {
                    break;
                }
            }
            if(t<0)
            {
                r=mid-1;
                mid=(l+r)/2;
            } else
            {
                //ans=mid;
                l=mid+1;
                mid=(l+r)/2;
            }
            //printf("%d %d %d\n",l,r,mid);
        }
        printf("%d\n",l-1);
    }
    return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值