pat 甲级 A1052 Linked List Sorting (25分) 静态数组排序

1052 Linked List Sorting (25分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.Then N lines follow, each describes a node in the format:
Address Key Next
where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001

11111 100 -1

00001 0 22222

33333 100000 11111

12345 -1 33333

22222 1000 12345

Sample Output:

5 12345

12345 -1 00001

00001 0 11111

11111 100 22222

22222 1000 33333

33333 100000 -1

题意
题目第一行先给而出n和首地址
后面的行就是 [首地址,内容(int),下一个指针地址]
要对内容做一个排序,从小到大,然后按题目给的输入格式进行输出

算法(其实也就是算法笔记里给出的模板):
步骤1.定义静态链表,其中结点性质由bool类型的flag定义,表示为结点在链表中是否出现。flag为false表示无效结点(不在链表上的节点)。
步骤2.初始化数组,令flag均为false(即0),表示初始状态下所有的节点都是无效节点。
步骤3.由题目给出的链表首地址first遍历整条链表,并标记有效节点的flag为true,同时计数有效节点的个数count。
步骤4.对节点进行排序,排序函数cmp的排序原则是:如果cmp的两个参数节点中有无效节点,则按flag从大到小排序,以把有效节点排到数组左端(因为有效节点的flag为1,大于无效节点的flag);否则按数据从小到大排序。
步骤5.由于有效节点已经按照数据域从小到大排序,因此按要求输出有效节点即可。

上代码

#include <iostream>
#include <algorithm>
const int maxn =100005;
using namespace std;
struct Node{
	int next;
	int data;
	int address;
	bool flag;
}node[maxn];
bool cmp(Node a,Node b)
{
	if(a.flag==false||b.flag==false)
		return a.flag>b.flag;
	else
		return  a.data<b.data;
}
int main()
{
	for(int i=0;i<maxn;i++)
	{
		node[i].flag=false;
	}
    int n,first;
	scanf("%d %d",&n,&first);
	int data,address,next;
	for(int i=0;i<n;i++)
	{
		scanf("%d ",&address);
		scanf("%d %d",&data,&next);
		node[address].data=data;
		node[address].address=address;
		node[address].next=next;
	}
	int p,count=0;
	p=first;
	while(p!=-1)
	{
		node[p].flag=true;
		count++;
		p=node[p].next;
	}
	if(!count)
	{
		printf("0 -1");	
	}else{
		sort(node,node+maxn,cmp);
		printf("%d %05d\n",count,node[0].address);
		for(int i =0;i<count;i++)
		{
			if(i!=count-1)
			{printf("%05d %d %05d\n",node[i].address,node[i].data,node[i+1].address);}
			else{
				printf("%05d %d -1\n",node[i].address,node[i].data);
			}
		}
	}
}

写在最后:
有一个小彩蛋啊,给大家也一起思考一下,倒数第二个printf最后一个如果写成node[i].next就会有三个用例报错,这是为啥呢?(明早起来想)
在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值