1086 Tree Traversals Again(甲级)

1086 Tree Traversals Again (25分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:

3 4 2 6 5 1
思路:
每次访问新节点就把他入栈,这个过程和先序序列总是先访问根节点的性质是相同的,push的次序就是先序遍历元素的顺序,pop则是按左子树,根节点,右子树的顺序进行的,因此pop是中序遍历的过程。
求出先序和中序遍历结果,建树,输出后序。

#include<iostream>
#include<vector>
#include<queue>
#include<stack>
using namespace std;
struct node {
	int data;
	node* lchild;
	node* rchild;
};
vector<int>pre, mid;//存储先序遍历和后序遍历结果
int n,flag=0;
//先序遍历序列区间为【prel,prer】,中序遍历序列为【midl,midr】;
//create函数返回构建的树的根节点地址
node* create(int prel, int prer, int midl, int midr)
{
	if (prel > prer)
	{
		return nullptr;//先序序列长度小于0,返回
	}
	node* root = new node;//新建节点存放当前二叉树根节点
	root->data = pre[prel];
	int j =midl;//存储中序序列中等于pre【prel】的节点下标
	for (j; j <= midr; j++)
	{
		if (mid[j] == pre[prel])
		{
			break;
		}
	}
	int num_left = j - midl;//左子树长度
	root->lchild = create(prel + 1, prel+num_left, midl, j - 1);
	root->rchild = create(prel+num_left+1, prer, j + 1, midr);
	return root;
}

void postorder(node* root)
{
	if (root)
	{
		postorder(root->lchild);
		postorder(root->rchild);
		if (flag++ == 0)cout << root->data;
		else cout << " " << root->data;
	}
}

int main()
{
	cin >> n;
	string str;
	int value;
	stack<int>s;
	for (int i = 0; i < 2 * n; i++)
	{
		cin >> str;
		if (str == "Push")//存入先序遍历数组
		{
			cin >> value;
			s.push(value);
			pre.push_back(value);
		}
		else//存入中序遍历数组
		{
			value = s.top();
			s.pop();
			mid.push_back(value);
		}
	}
	node* root = create(0, n - 1, 0, n - 1);
	postorder(root);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值