PAT甲级1001

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:

-1000000 9

Sample Output:

-999,991

这题我采用了两种方法
第一种是我最原始的想法,很直接,但是显然没动脑筋思考,而且开始还得不了满分
因为数不是很大,可以直接分类,把和的大小分三种情况然后对应求解就行
注意! 开始我一直报错的点就是比如说对于15553 1515
和为17068 但是我的结果是17,68;因为我最开始用的cout,然后就没考虑那么多,诸君引以为戒吧

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
	int a,b,c=0;
	cin>>a>>b;
	c=a+b;
	if(c<0)
	{
		cout<<"-";
		c=-c;
	}
	if(c>999999)
	{
		cout<<c/1000000<<",";
		printf("%03d,%03d",(c%1000000)/1000,c%1000);
	}
	else if(c>999&&c<=999999)
	{
		cout<<c/1000<<",";
		printf("%03d",c%1000);
	}
	else
	cout<<c;
}

第二种方法是我借鉴柳神的博客,其实我开始并不知道string s=to_string(a+b);这是涨姿势了,而且这个是c++11里的,如果版本比较低需要自行百度解决方法了。我在处理判断是否应该输出逗号的时候和柳神的方法不一样,我觉得我这个更容易理解一点吧。

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
int main()
{
	int a,b;
	cin>>a>>b;
	string s=to_string(a+b);
	int len=s.length();
	for(int i=0;i<len;i++)
	{
		cout<<s[i];
		if(s[i]=='-')
		continue;
		if((len-i-1)%3==0&&i!=len-1)
		cout<<",";
	}
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值