线性结构4 Pop Sequence C++实现

线性结构4 Pop Sequence C++实现
#题目
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
**

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

#c++代码

#include<iostream>

using namespace std;

int push(int* stack,int num,int M)
{
	if (stack[0] < M-1)
	{
		stack[0]++;
		stack[stack[0]] = num;
		return 1;
	}	
	else
		return 0;
	
}
int pop(int* stack)
{
	if (stack[0] > 0)
	{
		//stack[0]--;
		return stack[stack[0]--];
	}	
	else return -1;
}
void clear(int* stack)
{
	stack[0] = 0;
}
int main()
{
	int M = 0, N = 0, K = 0;
	cin >> M >> N >> K;
	int** p = new int*[K];
	int* stack = new int[M+1];
	stack[0] = 0;
	for (int i = 0; i < K; i++)
	{
		p[i] = new int[N];
	}
	for (int i = 0; i < K; i++)
	{
		for (int j = 0; j < N; j++)
		{
			cin >> p[i][j];
		}
	}
	int n1 = 1;
	int n2 = 0;
	for (int i = 0; i < K; i++)
	{
		n1 = 1;
		n2 = 0;
		while(true)
		{
			if (n1 <= N)
			{
				if (p[i][n2] > n1)
				{
					if (push(stack, n1, M)==0)
					{
						cout << "NO" << endl;
						break;
					}
					else n1++;
				}
					
				else if (p[i][n2] == n1)
				{
					n2++;
					n1++;
				}
				else
				{
					if (p[i][n2] == pop(stack))
						n2++;
					else
					{
						cout << "NO" << endl;
						break;
					}
					
				}
			}
			else
			{
				if (p[i][n2] == pop(stack))
					n2++;
				else
				{
					cout << "NO" << endl;
					break;
				}
			}
			if (n2 > N - 1)
			{
				cout << "YES" << endl;
				break;
			}
		}
		if(i!=4)
			clear(stack);
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值