poj1275差分约束

http://poj.org/problem?id=1275

Description

A supermarket in Tehran is open 24 hours a day every day and needs a number of cashiers to fit its need. The supermarket manager has hired you to help him, solve his problem. The problem is that the supermarket needs different number of cashiers at different times of each day (for example, a few cashiers after midnight, and many in the afternoon) to provide good service to its customers, and he wants to hire the least number of cashiers for this job.

The manager has provided you with the least number of cashiers needed for every one-hour slot of the day. This data is given as R(0), R(1), …, R(23): R(0) represents the least number of cashiers needed from midnight to 1:00 A.M., R(1) shows this number for duration of 1:00 A.M. to 2:00 A.M., and so on. Note that these numbers are the same every day. There are N qualified applicants for this job. Each applicant i works non-stop once each 24 hours in a shift of exactly 8 hours starting from a specified hour, say ti (0 <= ti <= 23), exactly from the start of the hour mentioned. That is, if the ith applicant is hired, he/she will work starting from ti o’clock sharp for 8 hours. Cashiers do not replace one another and work exactly as scheduled, and there are enough cash registers and counters for those who are hired.

You are to write a program to read the R(i) 's for i=0…23 and ti 's for i=1…N that are all, non-negative integer numbers and compute the least number of cashiers needed to be employed to meet the mentioned constraints. Note that there can be more cashiers than the least number needed for a specific slot.

Input

The first line of input is the number of test cases for this problem (at most 20). Each test case starts with 24 integer numbers representing the R(0), R(1), …, R(23) in one line (R(i) can be at most 1000). Then there is N, number of applicants in another line (0 <= N <= 1000), after which come N lines each containing one ti (0 <= ti <= 23). There are no blank lines between test cases.

Output

For each test case, the output should be written in one line, which is the least number of cashiers needed.
If there is no solution for the test case, you should write No Solution for that case.

Sample Input

1
1 0 1 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1
5
0
23
22
1
10

Sample Output

1
代码


  #include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 1010
#define INF 0x3f3f3f
using namespace std;
struct node
{
    int v,d,next;
}edge[maxn];
int cnt,head[30],d[30],vis[30],n,R[30],t[30],mid;
void add(int u,int v,int d)
{
    edge[cnt].v=v;
    edge[cnt].d=d;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
queue<int >q;
void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
	memset(d,-INF,sizeof(d));
	memset(vis,0,sizeof(vis));
	while(!q.empty())q.pop();
}

int spfa()
{
    d[0]=0;
    q.push(0);
    vis[0]=1;
    while(!q.empty())
    {
        int x=q.front();q.pop();
        vis[x]=0;
        if(x==24&&d[x]>mid)return 0;
        for(int i=head[x];i!=-1;i=edge[i].next)
        {
            int t=edge[i].v;
            if(d[t]<d[x]+edge[i].d)
            {
                d[t]=d[x]+edge[i].d;
                if(!vis[t])
                {
                    q.push(t);
                    vis[t]=1;
                }
            }
        }
    }
    return d[24]==mid?1:0;
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        
        for(int i=0;i<24;i++)
            scanf("%d",&R[i]);
        int m,a;
        scanf("%d",&m);
        memset(t,0,sizeof(t));
        for(int i=0;i<m;i++)
        {
            scanf("%d",&a);
            t[a]++;
        }
        int l=-1,r=m+1;
        while(r-l>1)
        {
            mid=(l+r)/2;
			init();
            for(int i=7;i<=23;i++)add(i-7,i+1,R[i]);
            for(int i=0;i<7;i++)  add(i+17,i+1,R[i]-mid);
            for(int i=0;i<=23;i++)add(i,i+1,0),add(i+1,i,-t[i]);
            add(0,24,mid);add(24,0,-mid);
            if(spfa())r=mid;
            else l=mid;
        }
        l>=m?printf("No Solution\n"):printf("%d\n",r);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值