POJ 1004

POJ 1004

原题
Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output

$1581.42

翻译
描述

拉里今年毕业,终于找到了工作。他赚了很多钱,但是似乎永远都还不够。拉里已决定,他需要掌握自己的金融资产并解决其融资问题。第一步是弄清楚他的钱怎么了。拉里(Larry)有他的银行帐户对帐单,想看看他有多少钱。通过编写程序来帮助拉里获取过去十二个月中每个月的期末余额,并计算其平均帐户余额。
输入项

输入将是十二行。每行将包含其特定月份银行帐户的期末余额。每个数字都是正数并显示在便士中。不包括美元符号。
输出量

输出将是一个数字,即十二个月期末余额的平均值(均值)。它会四舍五入到最接近的一分钱,并立即在前面加一个美元符号,然后在行尾。输出中将没有其他空格或字符。
样本输入

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
样本输出

$ 1581.42

下面是AC代码,需要注意的就是输出格式

#include <stdio.h>
int main()
{
	int i;
	float month[12];
	float sum=0;
	for(i=0;i<12;++i)
	{
		scanf("%f",&month[i]);
		sum+=month[i];
	}
	printf("$%.2f\n",sum*1.0/12);
	return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值