Just Skip The Problem

Just Skip The Problem

Problem Description

Y_UME has just found a number x in his right pocket. The number is a non-negative integer ranging from 0 to 2n−1 inclusively. You want to know the exact value of this number. Y_UME has super power, and he can answer several questions at the same time. You can ask him as many questions as you want. But you must ask all questions simultaneously. In the i-th question, you give him an integer yi ranging from 0 to 2n−1 inclusively, and he will answer you if x&yi equals to yi or not. Note that each question you ask has a index number. Namely, the questions are ordered in certain aspect. Note that Y_UME answer all questions at the same time, which implies that you could not make any decision on the remaining questions you could ask according to some results of some of the questions.

You want to get the exact value of x and then minimize the number of questions you will ask. How many different methods may you use with only minimum number of questions to get the exact value of x? You should output the number of methods modulo 106+3.

Two methods differ if and only if they have different number of questions or there exsits some i satisfying that the i-th question of the first method is not equal to the i-th of the second one.

Input

There are multiple test cases.

Each case starts with a line containing one positive integer n(n≤109).

Output

For each test case, output one line containing an integer denoting the answer.

Sample Input

2

Sample Output

2

&是二进制比较
比如n=4,那么只有1000,0100,0010,0001能最小次数精确的猜出他兜里的数字,题意得问的顺序不同方案数不同,所以A44,答案为n!。
数据开到109,但是当n>=mod时就输出0,因为都会是mod的倍数
Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const ll mod=1e6+3;
int main()
{
    ll n;
    while(~scanf("%lld",&n))
    {
        ll ans=1;
        if(n>=mod)
        {
            printf("0\n");
        }
        else
        {
            for(int i=1; i<=n; i++)
            {
                ans*=i;
                ans%=mod;
            }
            printf("%lld\n",ans);
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值