HDU6620 Just an Old Puzzle

Just an Old Puzzle

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 364 Accepted Submission(s): 228

Problem Description
You are given a 4 × 4 grid, which consists of 15 number cells and an empty cell.
All numbers are unique and ranged from 1 to 15.
In this board, the cells which are adjacent with the empty cell can move to the empty cell.
Your task is to make the input grid to the target grid shown in the figure below.
In the following example (sample input), you can get the target grid in two moves.

在这里插入图片描述

Input
The first line contains an integer T (1 <= T <= 10^5) denoting the number of test cases.
Each test case consists of four lines each containing four space-separated integers, denoting the input grid. 0 indicates the empty cell.

Output
For each test case, you have to print the answer in one line.
If you can’t get the target grid within 120 moves, then print ‘No’, else print ‘Yes’.

Sample Input

2
1 2 3 4
5 6 7 8
9 10 0 12
13 14 11 15
1 2 3 4
5 6 7 8
9 10 11 12
13 15 14 0

Sample Output

Yes
No

HINT
在这里插入图片描述
逆反数就是前面的数比后面的数大a[i]>a[j]
Code:

#include <bits/stdc++.h>
using namespace std;
int main( )
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int a[20];
        memset(a,0,sizeof(a));
        int flag;
        for(int i=1; i<=16; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]==0)
            {
                flag=i/4+(i%4!=0);
            }
        }

        int abs=0;
        for(int i=1; i<=16; i++)
        {
            if(a[i]==0)
                continue;
            for(int j=i+1; j<=16; j++)
            {
                if(a[j]==0)
                {
                    continue;
                }
                if(a[i]>a[j])
                    abs++;
            }
        }
        //printf("%d %d\n",abs,flag);
        if(flag%2==0&&abs%2==0||flag%2==1&&abs%2==1)
            printf("Yes\n");
        else
            printf("No\n");

    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值