POJ 2653 Pick-up sticks

Pick-up sticks

Time Limit: 3000MS Memory Limit: 65536K

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.在这里插入图片描述

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

题意:

就是判断线段是否是在最上面,也就是说如果线段相交,那么后出现的线段肯定就在刚开始出现的线段的上面了。

思路:

也就是遍历一个在 i i i线段后面的出现的 j j j线段,假如都不想交,那么此线段肯定就在最上面了。
判断线段想不想交:

  • 线段平行:观察是否有线段 i i i的一个端点在线段 j j j中间,如果有,有一定相交。
  • 线段不平行:求出线段的相交的点,假如这个点在两条线段的中间,那么这两条线段一定相交,
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1e+5 + 10;
const double eps = 1e-8;
double add(double a, double b) {
    if (fabs(a + b) < eps * (fabs(a) + fabs(b))) return 0;
    else return a + b;
}
struct P {
    double x;
    double y;
    P () {}
    P (double x, double y) : x(x), y(y) {}
    P operator + (P p) {
        return P(add(x, p.x), add(y, p.y));
    }
    P operator - (P p) {
        return P(add(x, -p.x), add(y, -p.y));
    }
    P operator * (double d) {
        return P(x * d, y * d);
    }
    double dot(P p) {
        return add(x * p.x, y * p.y);
    }
    double det(P p) {
        return add(x * p.y, -y * p.x);
    }
};
struct Line {
    P s, e;
    Line () {}
    Line(P s, P e) : s(s), e(e) {}
};
Line line[maxn];
bool on_seg(P p1, P p2, P q) {
    return (p1 - q).det(p2 - q) == 0 && (p1 - q).dot(p2 - q) <= 0;
}
P intersection(P p1, P p2, P q1, P q2) {
    return p1 + (p2 - p1) * ((q2 - q1).det(q1 - p1) / (q2 - q1).det(p2 - p1));
}
int main() {
    int n;
    double x1, x2, y1, y2;
    while (scanf("%d", &n) != EOF && n) {
        for (int i = 1; i <= n; i++) {
            scanf("%lf %lf %lf %lf", &x1, &y1, &x2, &y2);
            line[i] = Line(P(x1, y1), P(x2, y2));
        }
        printf("Top sticks: ");
        bool book = false;
        for (int i = 1; i <= n; i++) {
            bool flag = false;
            for (int j = i + 1; j <= n; j++) {
                if ((line[i].s - line[i].e).det(line[j].s - line[j].e) == 0) {
                    if (on_seg(line[i].s, line[i].e, line[j].s) || on_seg(line[i].s, line[i].e, line[j].e)) {
                        flag = true;
                        break;
                    }
                } else {
                    P r = intersection(line[i].s, line[i].e, line[j].s, line[j].e);
                    if (on_seg(line[i].s, line[i].e, r) && on_seg(line[j].s, line[j].e, r)) {
                        flag = true;
                        break;
                    }
                }
            }
            if (flag == false) {
                if (book == true) printf(", ");
                printf("%d", i);
                book = true;
            }
         }
         printf(".\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值