POJ 3368 Frequent values

Frequent values

Time Limit: 2000MS Memory Limit: 65536K

Description

You are given a sequence of n integers a1 , a2 , … , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , … , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , … , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, …, n}) separated by spaces. You can assume that for each i ∈ {1, …, n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

题意:

题目要求我们求出在一段区间中连续的相同的数字的最大值是多少。

思路:

看到区间求最大值的问题,可以想到是RMQ问题,然后我们可以将连续且相等的次数存进对应的数组里面,接着查询最大的次数就行了,但是需要注意的是。假如刚开始有部分在外面的时候,比如1 1 1 2 2,查询2 5,如果按照之前的思维,那么最大的就是num[3]=3,查询出来的也就会是3了,但是确实2,所以要提前将1 1 1单独提取出来进行比较判断。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int num[maxn], dp[maxn][20], mm[maxn];
void BuildRmq(int n) {
    mm[0] = -1;
    for (int i = 1; i <= n; i++) {
        mm[i] = mm[i - 1];
        if ((i & (i - 1)) == 0) mm[i]++;
        dp[i][0] = num[i];
    }
    for (int j = 1; j <= mm[n]; j++) {
        for (int i = 1; i + (1 << j) - 1 <= n; i++) {
            dp[i][j] = max(dp[i][j - 1], dp[i + (1 << (j - 1))][j - 1]);
        }
    }
}
int Rmq(int l, int r) {
    int k = mm[r - l + 1];
    return max(dp[l][k], dp[r - (1 << k) + 1][k]);
}
int main() {
    int n, m, x, temp = -1;
    while (scanf("%d", &n) != EOF && n) {
        memset(num, 0, sizeof(num));
        memset(dp, 0, sizeof(dp));
        scanf("%d", &m);
        for (int i = 1; i <= n; i++) {
            scanf("%d", &x);
            if (x == temp) num[i] = num[i - 1] + 1;
            else {
                temp = x;
                num[i] = 1;
            }
        }
        BuildRmq(n);
        int l, r;
        while (m--) {
            scanf("%d %d", &l, &r);
            int temp = l;
            while (temp <= r && num[temp] == num[temp - 1] + 1) temp++;
            printf("%d\n", max(Rmq(temp, r), temp - l));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值