POJ 2229 Sumsets

Sumsets

Time Limit: 2000MS Memory Limit: 200000K

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

  1. 1+1+1+1+1+1+1
  2. 1+1+1+1+1+2
  3. 1+1+1+2+2
  4. 1+1+1+4
  5. 1+2+2+2
  6. 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

思路:

本题相当于分成,有1和没1的情况,有1的话等价于i-1,没1的话说明都是2的幂次,方案数等价于全部缩小一倍,比如7,如果拆开的里面有1,那么相当于最前面加了个1,后面就是6的情况,如果没有1,也就是都是2.4.8这类的组合,问等于多少,那就可以看成2,4,8缩小一倍以后的总方案数,相当于比如问只能用2.4.8.16…组合32的方案数,那其实就等于用1.2.4.8.16…组合16的个数,而这个是个子问题

#include <iostream>
using namespace std;
const int maxn = 1e+9;
int dp[1000010];
int main() {
	int n;
	cin >> n;
	dp[1] = 1;
	for (int i = 2; i <= n; i++) {
		if (i % 2 == 1) dp[i] = dp[i - 1] % maxn;
		else dp[i] = (dp[i - 1] + dp[i / 2]) % maxn;
	}
	cout << dp[n] << endl;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值