POJ 2385 Apple Catching

Apple Catching

Time Limit: 1000MS Memory Limit: 65536K

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

  • Line 1: Two space separated integers: T and W

  • Lines 2…T+1: 1 or 2: the tree that will drop an apple each minute.
    Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6
Hint

INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

思路:

本题当贝西从i-1到i的时候,假如不移动,那么dp[i][j] = dp[i - 1][j],因为没有移动的时候,不消耗体力,也就只有从前一个不消耗体力中赋值,当开始消耗体力的时候,就比较dp[i - 1][j - 1], dp[i - 1][j],取决于移动后的苹果数和移动体力少的苹果数量谁更大,比如j=1的时候,可以从原来移动一次后的树选择不移动,也可以选择从原来不移动的树选择移动一次,因此就有dp[i][j] = max(dp[i - 1][j - 1], dp[i - 1][j])的状态方程,而假如呆在的树和苹果掉落的树一样的时候dp[i][j]++也就有了if (j % 2 + 1 == a[i]) dp[i][j]++;因为原来是1那么移动一次就变成了2在移动一次就变成了1.

#include <iostream>
#include <algorithm> 
using namespace std;
int dp[1010][40] = {0};
int main() {
	int n, m, maxn = 0;
	int a[1010] = {0};
	cin >> n >> m;
	for (int i = 1; i <= n; i++) cin >> a[i];
	for (int i = 1; i <= n; i++) {
		for (int j = 0; j <= m; j++) {
			if (j > 0) dp[i][j] = max(dp[i - 1][j - 1], dp[i - 1][j]);
			else dp[i][j] = dp[i - 1][j];
			if (j % 2 + 1 == a[i]) dp[i][j]++;
			maxn = max(maxn , dp[i][j]);
		}
	}
	cout << maxn;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值