POJ 3279 Fliptile

Fliptile

Time Limit: 2000MS Memory Limit: 65536K

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

思路:

挺麻烦的一道题目,就是先从最上边的一行开始,总共有2 ^ m种排列方式,然后每种再进行分析,分析每个点的是否符合题意,这个时候就要看这个点的周围了,这题最主要的翻面思路就是后面的一行去纠正前面一行的翻面问题,因为如果前一行的有问题,那么后面的那个翻面也会导致前面的一个翻面,这样就可以用后的去矫正前面的了,所以最后只要查看最后一行是否符合题意就知道是否全部符合题意了。

#include <iostream>
#include <cstring>
using namespace std;
int a[20][20], f[20][20], re[20][20];
int n, m;
int getnum(int x, int y) {
	int sum = a[x][y];
	int dis[5][2] = {0, 1, 1, 0, 0, 0, 0, -1, -1, 0};
	for (int i = 0; i < 5; i++) {
		int tx = x + dis[i][0];
		int ty = y + dis[i][1];
		if (tx >= 0 && tx < n && ty >= 0 && ty < m) sum += f[tx][ty];
	}
	return sum & 1;
}
int step() {
	for (int i = 1; i < n; i++) {
		for (int j = 0; j < m; j++) {
			if (getnum(i - 1, j) != 0) f[i][j] = 1;
		}
	}
	for (int i = 0; i < m; i++) {
		if (getnum(n - 1, i) != 0) return -1;
	}
	int res = 0;
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < m; j++) {
			res += f[i][j];
		}
	}
	return res;
}
int main() {
	scanf("%d %d", &n, &m);
	for (int i = 0; i < n ; i++) {
		for (int j = 0; j < m; j++) {
			scanf("%d", &a[i][j]);
		}
	}
	int res = -1;
	for (int i = 0; i < 1 << m; i++) {
		memset(f, 0, sizeof(f));
		for (int j = 0; j < m; j++) {
			f[0][j] = i >> j & 1;
		}
		int num = step();
		if (num >= 0 && (res < 0 || num < res)) {
			res = num;
			memcpy(re, f, sizeof(f));
		} 
	}
	if (res < 0) {
		cout << "IMPOSSIBLE\n";
		return 0;
	}
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < m; j++) {
			if (j != 0) cout << " ";
			cout << re[i][j];
		}
		cout << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值