POJ 2528 Mayor's posters

Mayor’s posters

Time Limit: 1000MS Memory Limit: 65536K

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
在这里插入图片描述

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

思路:

线段树+离散化的题目,
1 首先先将这些现段离散化,就是将重合线段消除,这样可以有效减少内存以及时间的使用量,比如1 6和2 5这个中间的3 4是重合的是包含在里面的没有必要去计算,这样就用离散化的方法去解决。(主函数中在建树之前的操作都是离散化的操作)
2 建树 参照模板就行了
3 更新 因为如果覆盖后底下的可能就看不见了,所以就要去标记这个区间,假如某个区间覆盖到了有标记的区间上面,这个有标记区间就要往下走(这个样就是被覆盖,和等下的查询有关系)。
4 查询 就是从根结点开始遍历如果出现了标记,就+1,但是还要考虑一种情况,就是一个区间但是在线段树上为两个区间,这样的话就要另外设一个数组标记已经访问过的区间。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e+4 + 10;
struct NODE {
    int l;
    int r;
    int flag;
    int mid () {
        return (l + r) >> 1;
    }
};
NODE node[maxn << 2 + 10];
struct DISC {
    int num;
    int id;
    bool friend operator < (DISC a, DISC b) {
        return a.num < b.num;
    }
};
DISC disc[maxn << 2];
int map[maxn << 2], book[maxn << 1];
void BuildTree(int l, int r, int rt) {
    node[rt].l = l;
    node[rt].r = r;
    node[rt].flag = 0;
    if (l == r) return ;
    int m = node[rt].mid();
    BuildTree(l, m, rt << 1);
    BuildTree(m + 1, r, rt << 1 | 1);
}
void UpdataTree(int c, int l, int r, int rt) {
    if (node[rt].l == l && node[rt].r == r) {
        node[rt].flag = c;
        return ;
    }
    if (node[rt].flag) {
        node[rt << 1].flag = node[rt << 1 | 1].flag = node[rt].flag;
        node[rt].flag = 0;
    }
    int m = node[rt].mid();
    if (r <= m) UpdataTree(c, l, r, rt << 1);
    else if (l > m) UpdataTree(c, l, r, rt << 1 | 1);
    else {
        UpdataTree(c, l, m, rt << 1);
        UpdataTree(c, m + 1, r, rt << 1 | 1);
    }
}
int ans = 0;
void Query(int rt) {
    if (node[rt].flag) {
        if (!book[node[rt].flag]) {
            book[node[rt].flag] = true;
            ans++;
        }
        return ;
    }
    Query(rt << 1);
    Query(rt << 1 | 1);
}
int main() {
    int n, t;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);
        for (int i = 0; i < n; i++) {
            scanf("%d %d", &disc[i].num, &disc[i + n].num);
            disc[i].id = i;
            disc[i + n].id = i + n;
        }
        sort(disc, disc + 2 * n);
        int cnt = 0, temp = -1;
        for (int i = 0; i < n * 2; i++) {
            if (temp != disc[i].num) {
                cnt++;
                temp = disc[i].num;
            }
            map[disc[i].id] = cnt;
        }
        BuildTree(1, cnt, 1);
        for (int i = 0; i < n; i++) {
            UpdataTree(i + 1, map[i], map[i + n], 1);
        }
        memset(book, false, sizeof(book));
        ans = 0;
        Query(1);
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值